@MoogleMaestro@lemmy.zip

member since 26 Jul 2024 20:52

posts

The Steam Frame Is More Than Just Another VR Headset - Aftermath (Chris Person)

Aftermath The Steam Frame Is More Than Just Another VR Headset
preview

Conclusion below, but full read is highly recommended:

#The Frame

The Steam Frame is not for everyone; I’d argue VR isn’t generally. But despite taking far longer than it should have to materialize and costing more than I’d like, the Steam Frame is one of the most exciting pieces of hardware I’ve seen in the space in years, one that gave me that same feeling of optimism that the Index did so years ago. The Frame builds on the work done by its competitors in the years since the Index and solves so many friction points I’d had to actually engaging with VR as a medium at all. It is a device that is doing massive amounts of hard work to unify several different use cases into a single open platform, and, despite its individual parts being less novel, that unity is game changing. It is hardware whose importance may ultimately eclipse its remit, one with potentially massive consequences for PC gaming, but on its own terms it hits the sweet spot that I’ve yearned for so much from a successor. I only pray we do not have to wait another seven years for more.

Podman: Issues with multiple users running containers simultaneously

preview

Self cross-posting from: lemmy.zip/post/70909658

Intention to have slightly better visibility from the self-hosted crowd and I’m interested in more general feedback on this too.

Hey everyone! I’m trying to find a solution to a really confusing problem…

I have the following simple nginx docker compose configuration on my Fedora home server that I can run without issue on my uid 1000 user, lets call this user “userA”.

services:
  nginx:
    container_name: nginx-alt
    image: docker.io/library/nginx
    restart: unless-stopped
    ports:
      - 8181:80

This exposes internal port 80 as 8181 and can be accessed in a lan in the expected matter.

However, for security reasons, I want to actually host this service eventually on a completely different user with less permissions. Let’s call this user “userB” who has a very limited scope of the file system. This is to prevent potential escaping of the rootless container causing major file system havoc (i.e. reduce the scope of the user to a very limited network of containers.)

The problem is really simple: For some reason, when userB runs this service (uid 1001), the nginx service suddenly complains about privileges. As a result, I get a “Forbidden 403” error when hosting. Turning off selinux has no affect (so setenforce 0 does nothing, meaning I can rule out secure linux interruption.)

The errors look like the following:

nginx-alt  | 2026/09/04 20:03:34 [error] 25#25: *1 "/usr/share/nginx/html/index.html" is forbidden (13: Permission denied), client: xx.xx.x.x, server: localhost, request: "GET / HTTP/1.1", host: "xxx.xxx.xxx.xxx:8181"
nginx-alt  | 10.89.0.2 - - [04/Sep/2026:20:03:34 +0000] "GET / HTTP/1.1" 403 153 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:155.0) Gecko/20100101 Firefox/155.0" "-"

For what it’s worth, both users should be relatively vanilla and all ports are appropriately exported. There shouldn’t be anything, for example, that is making userA run as “privileged” over the other users and podman should be running rootless in both containers.

I did see a note on the nginx image about running in rootless that I might try, but it doesn’t solve my bigger issue here which is the lack of consistency between the two users. Additionally, userns_mode: keep-ids only caused the container to fail to boot for other reason entirely.

There must be something fundamentally wrong with my configuration of my system. Has anyone had any experience running two podman containers on two different users simultaneously that can provide feedback?

Obviously, I’m not trying to run just an nginx server, but I found this to be the easiest configuration to reproduce.

comments